use strict;
my $str = 'sm:"sidudhusdh" eui:(duish iusds "sidus d" skdjhs)
th sdh dfj " dfhd\'jf \'ue " dhfdf sdlsjdklsj "djs dsh:djshd disdh:\'djksdhjs\' djshjdh:(djhsjds \'kdhjkd\') hd s"dfjlshds ';
my $regex = qr/(?<!(\s?)\S+:((?<quotetag>["']).*?\k<quotetag>|\(.*?\)|.*?(?=\s)|.*))((?<quote>["']).*?\k<quote>)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}