#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}) - - (\[\d{1,2}\/\w{3}\/\d{4}:\d{2}:\d{2}:\d{2} -\d{4}\]) "(GET|POST) \/\w*\/ \w*\/[1,2].[0-9]" (\d{3}) (\d{4})"
Local $sString = "127.0.0.1 - - [28/Jul/2006:10:27:32 -0300] "GET /hidden/ HTTP/1.0" 404 7218"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")