import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,3}.\\d{1,3}.\\d{1,3}.\\d{1,3}) - - (\\[\\d{1,2}\\/\\w{3}\\/\\d{4}:\\d{2}:\\d{2}:\\d{2} -\\d{4}\\]) \"(GET|POST) \\/\\w*\\/ \\w*\\/[1,2].[0-9]\" (\\d{3}) (\\d{4})";
final String string = "127.0.0.1 - - [28/Jul/2006:10:27:32 -0300] \"GET /hidden/ HTTP/1.0\" 404 7218";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}