const regex = /(\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}) - - (\[\d{1,2}\/\w{3}\/\d{4}:\d{2}:\d{2}:\d{2} -\d{4}\]) "(GET|POST) \/\w*\/ \w*\/[1,2].[0-9]" (\d{3}) (\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,3}.\\d{1,3}.\\d{1,3}.\\d{1,3}) - - (\\[\\d{1,2}\\\/\\w{3}\\\/\\d{4}:\\d{2}:\\d{2}:\\d{2} -\\d{4}\\]) "(GET|POST) \\\/\\w*\\\/ \\w*\\\/[1,2].[0-9]" (\\d{3}) (\\d{4})', 'gm')
const str = `127.0.0.1 - - [28/Jul/2006:10:27:32 -0300] "GET /hidden/ HTTP/1.0" 404 7218`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}