re = /(\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}) - - (\[\d{1,2}\/\w{3}\/\d{4}:\d{2}:\d{2}:\d{2} -\d{4}\]) "(GET|POST) \/\w*\/ \w*\/[1,2].[0-9]" (\d{3}) (\d{4})/m
str = '127.0.0.1 - - [28/Jul/2006:10:27:32 -0300] "GET /hidden/ HTTP/1.0" 404 7218'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end