using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#";
string input = @" #somecomment
# some comment
""#not a commnet"" #another comment
'#not a comment'
jquery_code = ""$('#some-identifier')[0].click()""#yet a comment, but the identifier :(
jquery_code = '$(""#some-identifier"")[0].click()'
# just another comment
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}