package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)#`)
var str = ` #somecomment
# some comment
"#not a commnet" #another comment
'#not a comment'
jquery_code = "$('#some-identifier')[0].click()"#yet a comment, but the identifier :(
jquery_code = '$("#some-identifier")[0].click()'
# just another comment
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}