// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)#").unwrap();
let string = " #somecomment
# some comment
\"#not a commnet\" #another comment
'#not a comment'
jquery_code = \"$('#some-identifier')[0].click()\"#yet a comment, but the identifier :(
jquery_code = '$(\"#some-identifier\")[0].click()'
# just another comment
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}