import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\*\\*Bewerbung von .*:\\*\\*\\n\\n\\*Name:\\* .*\\n\\*MC-Name:\\* .*\\n\\*Alter:\\* .*\\n\\*Aufgabe:\\* .*\\n\\*Vorteile:\\* .*\\n\\*Gründe:\\* .*)([\\w\\W]+)$";
final String string = "**Bewerbung von :**\n\n"
+ "*Name:* \n"
+ "*MC-Name:* \n"
+ "*Alter: Missing a `*` here, plan foiled!\n"
+ "*Aufgabe:* \n"
+ "*Vorteile:* \n"
+ "*Gründe:* ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}