using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"discord(?:app)?\.(?:com|gg)/[A-Za-z0-9-_]+";
string input = @"https://discord.gg/submit-a-ticket
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}