re = /discord(?:app)?\.(?:com|gg)\/[A-Za-z0-9-_]+/m
str = 'https://discord.gg/submit-a-ticket
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end