package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)discord(?:app)?\.(?:com|gg)/[A-Za-z0-9-_]+`)
var str = `https://discord.gg/submit-a-ticket
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}