$re = '~discord(?:app)?\.(?:com|gg)/[A-Za-z0-9-_]+~m';
$str = 'https://discord.gg/submit-a-ticket
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);