using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"From:\s*(\S*@\S*\.\S*)\s*To:\s*(\S*@\S*\.\S*)\s*Cc:\s*(\S*@\S*\.\S*)\s*Subject:\s*([\s\S]*)";
string input = @"From: trial@trial.com
To: trial@trial.com
Cc: trial@trial.com
Subject: Protecting Information and Data Privacy";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}