re = /From:\s*(\S*@\S*\.\S*)\s*To:\s*(\S*@\S*\.\S*)\s*Cc:\s*(\S*@\S*\.\S*)\s*Subject:\s*([\s\S]*)/
str = 'From: trial@trial.com
To: trial@trial.com
Cc: trial@trial.com
Subject: Protecting Information and Data Privacy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end