const regex = new RegExp('From:\\s*(\\S*@\\S*\\.\\S*)\\s*To:\\s*(\\S*@\\S*\\.\\S*)\\s*Cc:\\s*(\\S*@\\S*\\.\\S*)\\s*Subject:\\s*([\\s\\S]*)', 'g')
const str = `From: trial@trial.com
To: trial@trial.com
Cc: trial@trial.com
Subject: Protecting Information and Data Privacy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}