import re
regex = re.compile(r"From:\s*(\S*@\S*\.\S*)\s*To:\s*(\S*@\S*\.\S*)\s*Cc:\s*(\S*@\S*\.\S*)\s*Subject:\s*([\s\S]*)")
test_str = ("From: trial@trial.com \n\n"
"To: trial@trial.com \n\n"
"Cc: trial@trial.com \n\n"
"Subject: Protecting Information and Data Privacy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")