using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(?:,(?:(\[(?:[^][]++|\g<1>)*])|\d+))?$";
string input = @"1,[]
1,[0,0,0,[]]
1,[0,0,0,0,0,[]]
1,1
1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}