re = /^\d+(?:,(?:(\[(?:[^][]++|\g<1>)*])|\d+))?$/m
str = '1,[]
1,[0,0,0,[]]
1,[0,0,0,0,0,[]]
1,1
1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end