package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:,(?:(\[(?:[^][]++|\g<1>)*])|\d+))?$`)
var str = `1,[]
1,[0,0,0,[]]
1,[0,0,0,0,0,[]]
1,1
1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}