# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*)(?:\n\1.*)+/$1/gm;t' <<< "canon
cmap
cmapx
cmapx_np
dot
dot_json
eps
fig
gd
gd2
gif
gv
imap
imap_np
ismap
jpe
jpeg
jpg
json
json0
mp
pdf
pic
plain
plain-ext
png
pov
ps
ps2
svg
svgz
tk
vdx
vml
vmlz
vrml
wbmp
webp
x11
xdot
xdot1.2
xdot1.4
xdot_json
xlib"