using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)(?:\n\1.*)+";
string substitution = @"$1";
string input = @"canon
cmap
cmapx
cmapx_np
dot
dot_json
eps
fig
gd
gd2
gif
gv
imap
imap_np
ismap
jpe
jpeg
jpg
json
json0
mp
pdf
pic
plain
plain-ext
png
pov
ps
ps2
svg
svgz
tk
vdx
vml
vmlz
vrml
wbmp
webp
x11
xdot
xdot1.2
xdot1.4
xdot_json
xlib";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}