import Foundation
let pattern = #"^(.*)(?:\n\1.*)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
canon
cmap
cmapx
cmapx_np
dot
dot_json
eps
fig
gd
gd2
gif
gv
imap
imap_np
ismap
jpe
jpeg
jpg
json
json0
mp
pdf
pic
plain
plain-ext
png
pov
ps
ps2
svg
svgz
tk
vdx
vml
vmlz
vrml
wbmp
webp
x11
xdot
xdot1.2
xdot1.4
xdot_json
xlib
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)