#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<ROW(?=((?!ROW).)*<FROM>\d*412\d*<\/FROM>).*?<\/ROW>"
Local $sString = "<ROW num="381">" & @CRLF & _
" <TO>8549672167</TO>" & @CRLF & _
" <FROM>14121</FROM>" & @CRLF & _
" <TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>" & @CRLF & _
"</ROW>" & @CRLF & _
"<ROW num="382">" & @CRLF & _
" <TO>8549674167</TO>" & @CRLF & _
" <FROM>224111</FROM>" & @CRLF & _
" <TIME>5/10/2009 19:49:37</TIME>" & @CRLF & _
" <TEXT>Hme</TEXT>" & @CRLF & _
"</ROW>" & @CRLF & _
"<ROW num="381">" & @CRLF & _
" <TO>854967216741</TO>" & @CRLF & _
" <FROM>893674258412</FROM>" & @CRLF & _
" <TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>" & @CRLF & _
"</ROW>" & @CRLF & _
"" & @CRLF & _
"fasdf412"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")