re = /<ROW(?=((?!ROW).)*<FROM>\d*412\d*<\/FROM>).*?<\/ROW>/m
str = '<ROW num="381">
<TO>8549672167</TO>
<FROM>14121</FROM>
<TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>
</ROW>
<ROW num="382">
<TO>8549674167</TO>
<FROM>224111</FROM>
<TIME>5/10/2009 19:49:37</TIME>
<TEXT>Hme</TEXT>
</ROW>
<ROW num="381">
<TO>854967216741</TO>
<FROM>893674258412</FROM>
<TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>
</ROW>
fasdf412'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end