const regex = /<ROW(?=((?!ROW).)*<FROM>\d*412\d*<\/FROM>).*?<\/ROW>/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<ROW(?=((?!ROW).)*<FROM>\\d*412\\d*<\\\/FROM>).*?<\\\/ROW>', 'gms')
const str = `<ROW num="381">
<TO>8549672167</TO>
<FROM>14121</FROM>
<TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>
</ROW>
<ROW num="382">
<TO>8549674167</TO>
<FROM>224111</FROM>
<TIME>5/10/2009 19:49:37</TIME>
<TEXT>Hme</TEXT>
</ROW>
<ROW num="381">
<TO>854967216741</TO>
<FROM>893674258412</FROM>
<TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>
</ROW>
fasdf412`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}