import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<ROW(?=((?!ROW).)*<FROM>\\d*412\\d*<\\/FROM>).*?<\\/ROW>";
final String string = "<ROW num=\"381\">\n"
+ " <TO>8549672167</TO>\n"
+ " <FROM>14121</FROM>\n"
+ " <TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>\n"
+ "</ROW>\n"
+ "<ROW num=\"382\">\n"
+ " <TO>8549674167</TO>\n"
+ " <FROM>224111</FROM>\n"
+ " <TIME>5/10/2009 19:49:37</TIME>\n"
+ " <TEXT>Hme</TEXT>\n"
+ "</ROW>\n"
+ "<ROW num=\"381\">\n"
+ " <TO>854967216741</TO>\n"
+ " <FROM>893674258412</FROM>\n"
+ " <TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>\n"
+ "</ROW>\n\n"
+ "fasdf412";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}