#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\w)(?<!\w-\w)(?: ?-+ ?)+(?=\w)(?!\w-\w)"
Local $sString = "<!-- The following should match. Not the dashes in the comment tag, obviously ;P -->" & @CRLF & _
"<h2 class="chapter_title">Chapter 01 -- The Beginning</h2>" & @CRLF & _
"<h2 class="chapter_title">Chapter 02 - The Reckoning</h2>" & @CRLF & _
"<h2 class="chapter_title">Chapter 03 - - The Aftermath</h2>" & @CRLF & _
"<h2 class="chapter_title">Chapter 04--The Conclusion</h2>" & @CRLF & _
"<p>I was having the usual - cheeseburger and a cold beer.</p>" & @CRLF & _
"" & @CRLF & _
"<!-- The following should not match -->" & @CRLF & _
"<p>I was wearing a t-shirt.</p>" & @CRLF & _
"<p>It was a drunken mix-up</p>" & @CRLF & _
"<p>---</p>" & @CRLF & _
"<p>-----</p>" & @CRLF & _
"<p>- - -</p>" & @CRLF & _
"<p> - - </p>" & @CRLF & _
"<p> - - - </p>" & @CRLF & _
""
Local $sSubst = "—"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)