using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\w)(?<!\w-\w)(?: ?-+ ?)+(?=\w)(?!\w-\w)";
string substitution = @"—";
string input = @"<!-- The following should match. Not the dashes in the comment tag, obviously ;P -->
<h2 class=""chapter_title"">Chapter 01 -- The Beginning</h2>
<h2 class=""chapter_title"">Chapter 02 - The Reckoning</h2>
<h2 class=""chapter_title"">Chapter 03 - - The Aftermath</h2>
<h2 class=""chapter_title"">Chapter 04--The Conclusion</h2>
<p>I was having the usual - cheeseburger and a cold beer.</p>
<!-- The following should not match -->
<p>I was wearing a t-shirt.</p>
<p>It was a drunken mix-up</p>
<p>---</p>
<p>-----</p>
<p>- - -</p>
<p> - - </p>
<p> - - - </p>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}