import Foundation
let pattern = #"(?<=\w)(?<!\w-\w)(?: ?-+ ?)+(?=\w)(?!\w-\w)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<!-- The following should match. Not the dashes in the comment tag, obviously ;P -->
<h2 class="chapter_title">Chapter 01 -- The Beginning</h2>
<h2 class="chapter_title">Chapter 02 - The Reckoning</h2>
<h2 class="chapter_title">Chapter 03 - - The Aftermath</h2>
<h2 class="chapter_title">Chapter 04--The Conclusion</h2>
<p>I was having the usual - cheeseburger and a cold beer.</p>
<!-- The following should not match -->
<p>I was wearing a t-shirt.</p>
<p>It was a drunken mix-up</p>
<p>---</p>
<p>-----</p>
<p>- - -</p>
<p> - - </p>
<p> - - - </p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"—"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)