import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\w)(?<!\\w-\\w)(?: ?-+ ?)+(?=\\w)(?!\\w-\\w)";
final String string = "<!-- The following should match. Not the dashes in the comment tag, obviously ;P -->\n"
+ "<h2 class=\"chapter_title\">Chapter 01 -- The Beginning</h2>\n"
+ "<h2 class=\"chapter_title\">Chapter 02 - The Reckoning</h2>\n"
+ "<h2 class=\"chapter_title\">Chapter 03 - - The Aftermath</h2>\n"
+ "<h2 class=\"chapter_title\">Chapter 04--The Conclusion</h2>\n"
+ "<p>I was having the usual - cheeseburger and a cold beer.</p>\n\n"
+ "<!-- The following should not match -->\n"
+ "<p>I was wearing a t-shirt.</p>\n"
+ "<p>It was a drunken mix-up</p>\n"
+ "<p>---</p>\n"
+ "<p>-----</p>\n"
+ "<p>- - -</p>\n"
+ "<p> - - </p>\n"
+ "<p> - - - </p>\n";
final String subst = "—";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}