package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s+\/inference=".+)\n\s+(\s+([^\/\n]+\n){1,2})(\s+\/codon_start=.+)`)
var str = ` /inference="blah
blah
BLAH
/codon_start=blah
/inference="similar
/codon_start=blah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}