import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s+\\/inference=\".+)\\n\\s+(\\s+([^\\/\\n]+\\n){1,2})(\\s+\\/codon_start=.+)";
final String string = " /inference=\"blah\n"
+ " blah\n"
+ " BLAH\n"
+ " /codon_start=blah\n\n"
+ " /inference=\"similar\n"
+ " /codon_start=blah";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}