import re
regex = re.compile(r"(\s+\/inference=\".+)\n\s+(\s+([^\/\n]+\n){1,2})(\s+\/codon_start=.+)")
test_str = (" /inference=\"blah\n"
" blah\n"
" BLAH\n"
" /codon_start=blah\n\n"
" /inference=\"similar\n"
" /codon_start=blah")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")