#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\d{2}\/\d{2}\/\d{4}|₪ \d{1,3}(?:,\d{3})*(?:\.\d+)?| ?\w+(?: \w+)*)"
Local $sString = "2, some text,9740127,"₪ 38,850.00","₪ 5,550.00","₪ 28,305","₪ 4,995",22/05/2020" & @CRLF & _
""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)