using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\d{2}\/\d{2}\/\d{4}|₪ \d{1,3}(?:,\d{3})*(?:\.\d+)?| ?\w+(?: \w+)*)";
string substitution = @"\n";
string input = @"2, some text,9740127,""₪ 38,850.00"",""₪ 5,550.00"",""₪ 28,305"",""₪ 4,995"",22/05/2020
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}