re = /(?:\d{2}\/\d{2}\/\d{4}|₪ \d{1,3}(?:,\d{3})*(?:\.\d+)?| ?\w+(?: \w+)*)/m
str = '2, some text,9740127,"₪ 38,850.00","₪ 5,550.00","₪ 28,305","₪ 4,995",22/05/2020
'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result