import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^SAM(?:ANTHA)? +M(?:ARIA)? +SM(?:ITH)?$";
final String string = "SAMANTHA S SMITH\n"
+ "SAM M SMITH\n"
+ "SAMANTHA LORI SMITH\n"
+ "SAMANTHA MARIA SMITH";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}