const regex = /^SAM(?:ANTHA)? +M(?:ARIA)? +SM(?:ITH)?$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^SAM(?:ANTHA)? +M(?:ARIA)? +SM(?:ITH)?$', 'gim')
const str = `SAMANTHA S SMITH
SAM M SMITH
SAMANTHA LORI SMITH
SAMANTHA MARIA SMITH`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}