import re
regex = re.compile(r"^SAM(?:ANTHA)? +M(?:ARIA)? +SM(?:ITH)?$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("SAMANTHA S SMITH\n"
"SAM M SMITH\n"
"SAMANTHA LORI SMITH\n"
"SAMANTHA MARIA SMITH")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")