$re = '/^SAM(?:ANTHA)? +M(?:ARIA)? +SM(?:ITH)?$/im';
$str = 'SAMANTHA S SMITH
SAM M SMITH
SAMANTHA LORI SMITH
SAMANTHA MARIA SMITH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);