import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<)(?!\\s|(?:<)|(/?(EMPTY|[bui]|sup|sub|strong|strike|small|ul|ol|li|a|em|br\\s*/?|img|var|span|div|p|run\\d|style|center)(\\s+[^>]+)?(?:>))|/?[a-z]\\d+/?(?:>)).*?(?:>)|(?:<)[\\w.-]+@[\\w.-]+(?:>)|\\[(?i:COUNTRY)\\]";
final String string = "[COUNTRY]\n"
+ "[country]\n"
+ "[Country]\n"
+ "[foobar]\n"
+ "[FOOBAR]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}