re = /(?:<)(?!\s|(?:<)|(\/?(EMPTY|[bui]|sup|sub|strong|strike|small|ul|ol|li|a|em|br\s*\/?|img|var|span|div|p|run\d|style|center)(\s+[^>]+)?(?:>))|\/?[a-z]\d+\/?(?:>)).*?(?:>)|(?:<)[\w.-]+@[\w.-]+(?:>)|\[(?i:COUNTRY)\]/m
str = '[COUNTRY]
[country]
[Country]
[foobar]
[FOOBAR]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end