const regex = new RegExp('(?:<)(?!\\s|(?:<)|(/?(EMPTY|[bui]|sup|sub|strong|strike|small|ul|ol|li|a|em|br\\s*/?|img|var|span|div|p|run\\d|style|center)(\\s+[^>]+)?(?:>))|/?[a-z]\\d+/?(?:>)).*?(?:>)|(?:<)[\\w.-]+@[\\w.-]+(?:>)|\\[(?i:COUNTRY)\\]', 'gm')
const str = `[COUNTRY]
[country]
[Country]
[foobar]
[FOOBAR]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}