$re = '/(?:<)(?!\s|(?:<)|(/?(EMPTY|[bui]|sup|sub|strong|strike|small|ul|ol|li|a|em|br\s*/?|img|var|span|div|p|run\d|style|center)(\s+[^>]+)?(?:>))|/?[a-z]\d+/?(?:>)).*?(?:>)|(?:<)[\w.-]+@[\w.-]+(?:>)|\[(?i:COUNTRY)\]/m';
$str = '[COUNTRY]
[country]
[Country]
[foobar]
[FOOBAR]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);