using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+).*?>.*?<\/\1>";
string substitution = @"";
string input = @"a<script>console.log(""aaa"")</scr<a></a>ipt>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}