use strict;
my $str = 'a<script>console.log("aaa")</scr<a></a>ipt>';
my $regex = qr/<(\w+).*?>.*?<\/\1>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";