re = /<(\w+).*?>.*?<\/\1>/m
str = 'a<script>console.log("aaa")</scr<a></a>ipt>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result