$re = '/<(\w+).*?>.*?<\/\1>/m';
$str = 'a<script>console.log("aaa")</scr<a></a>ipt>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;