import re
regex = re.compile(r"^(?:\d{8}(?:\d{2}(?:\d{2})?)?|\(\+?\d{2,3}\)\s?(?:\d{4}[\s*.-]?\d{4}|\d{3}[\s*.-]?\d{3}|\d{2}([\s*.-]?)\d{2}\1\d{2}(?:\1\d{2})?))$", flags=re.MULTILINE)
test_str = ("It can contain open and close parenthesis ex. (55)\n"
"It can contin or not '+' char ex. (+52)\n"
"It can contain 2 or 3 numbers inside parenthesis ex. (+555) o (+55)\n"
"It can contain whitespace between close parenthesis and the next numbers ex. (55) 44332211\n"
"The consecutive numbers to the parenthesis must be 6 or 8 numbers ex. (55)443322 o (55)44332211\n"
"The consecutive numbers to the parenthesis can contain whitespaces, dashes, asterisks, or colons. ex.(55)44-33-22-11 o (55)44 33 22 11 o (55)44*33*22*11 o (55)44.33.22.11\n"
"The consecutive numbers to the parenthesis can be divided in groups of 2, 3 or 4 numbers ex. (55)5544-3322 o (55)55 44 33 22 o (555)444*333\n"
"The number format can come in a row of 8, 10 o 12 numbers ex. 55443322 o 5544332211 o 554433221100\n"
"(55)test\n"
"(55)333-test\n"
"(55)test 22\n"
"554433221100\n"
"5544332211\n"
"55443322\n"
"(55)443322\n"
"(55)44332211\n"
"(+55)443322\n"
"(+55)44332211\n"
"(55)4433*2211\n"
"(55)444.333\n"
"(55)44-33-22-11\n"
"(55)4433-2211\n"
"(+55)443 322")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")